Aria Operations UI displays the error:
On Admin UI, nodes show "Waiting for Analytics"
Logs (/logs/casa-webapp/casa.log) show errors as below:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'pakScriptLog' defined in class path resource [spring/casa-beans.xml]: Invocation of init method failed; nested exception is com.vmware.vcops.casa.exception.CasaException: Could not query_pak_env for pakID= ...... ... 186 moreCaused by: com.vmware.vcops.casa.exception.CasaException: Could not query_pak_env for pakID= ....... ... 193 moreCaused by: com.vmware.vcops.casa.support.CommandLineExitException: CommandLineExitException: key=general.failure; args=1,sudo: Account expired or PAM config lacks an "account" section for sudo, contact your system administratorsudo: a password is required
.....
Running command chage -l admin shows account as expired:
Aria Operations 8.18.x
This happens if the admin account has expired on the node(s) and hence, casa service fails to initialize.
chage -E -1 admin
chage -l admin