Aria Operations UI is inaccessible and All nodes show 'Waiting for Analytics' on Aria Operations Admin UI
search cancel

Aria Operations UI is inaccessible and All nodes show 'Waiting for Analytics' on Aria Operations Admin UI

book

Article ID: 447801

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Aria Operations UI displays the error:

On Admin UI, nodes show "Waiting for Analytics"

Logs (/logs/casa-webapp/casa.log) show errors as below:

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'pakScriptLog' defined in class path resource [spring/casa-beans.xml]: Invocation of init method failed; nested exception is com.vmware.vcops.casa.exception.CasaException: Could not query_pak_env for pakID=
      ......
        ... 186 more
Caused by: com.vmware.vcops.casa.exception.CasaException: Could not query_pak_env for pakID=
      .......
        ... 193 more
Caused by: com.vmware.vcops.casa.support.CommandLineExitException: CommandLineExitException: key=general.failure; args=1,sudo: Account expired or PAM config lacks an "account" section for sudo, contact your system administrator
sudo: a password is required
.....

Running command chage -l admin shows account as expired:

Environment

Aria Operations 8.18.x

Cause

This happens if the admin account has expired on the node(s) and hence, casa service fails to initialize.

Resolution

  1. Take an SSH via root account to the affected node(s)
  2. Change the expiry for admin account to 'never':  
    chage -E -1 admin
  3. Verify that the account expiry has changed to 'never':
    chage -l admin
  4. Restart the cluster as per the article here: Shutdown and Startup sequence for VCF/Aria Operations cluster