Error: Operation health error on vSAN disk after physical disk replacement
search cancel

Error: Operation health error on vSAN disk after physical disk replacement

book

Article ID: 447785

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

  • After physically replacing a faulty capacity or cache tier disk in a vSAN cluster, the vSAN Skyline Health reports an Operation health warning.

  • In the vSphere Client, navigating to Cluster > Configure > vSAN > Disk Management shows one disk on a specific host as Absent.

  • The newly replaced physical disk appears as Unclaimed in the vSAN disk management..

  • Hardware management consoles (e.g., HPE OneView, Dell iDRAC) report no errors for the physical disks.

Environment

VMware vSAN (All versions)

Cause

This issue occurs because the faulty disk's software reference (UUID) was not removed from the vSAN disk group configuration during the physical disk replacement. The ESXi host retains a stale UUID. And, newly added disks will show as unclaimed until it is manually added to the disk group.

Resolution

  1. Remove the Absent disk reference
    • Verify the DISK_UUID carefully before proceeding. This operation clears the stale reference from the cluster metadata.
    • In the vSphere Client, navigate to Cluster > Configure > vSAN > Disk Management.
    • Select the impacted host and click View Disks.
    • Select the Absent disk click Remove Disk.

  2. Claim the newly add disk healthy disk
    • In the vSphere Client, navigate to Cluster > Configure > vSAN > Disk Management.
    • Select the impacted host and click View Disks.
    • Select the disk group and click Add Disks.
    • Select the Unclaimed disk (the new physical drive) and click Add.

Additional Information

The vSAN disk appears as Absent in vSAN Disk Management
Requirements when replacing disks in a vSAN cluster