/var/log/vmware/vcf/domainmanager/domainmanager.log on the SDDC Manager/VCF Installer:YYYY/MM/DD HH:MM:SS Using appliance name from props: bootstrap-vm-0###hError: failed to find bootstrap VM 'bootstrap-vm-05###bh': failed to find VM /<Datacente_Name>/vm/vcf-management-services/bootstrap-vm-###h: vm '/<Cluster_name>vm/vcf-management-services/bootstrap-vm-0###Ubh' not foundYYYY/MM/DD HH:MM:SS error: failed to find bootstrap VM 'bootstrap-vm-05IUbh': failed to find VM /<Datacente_Name>/vm/vcf-management-services/bootstrap-vm-05###bh: vm '/C<Cluster_name>/vm/vcf-management-services/bootstrap-vm-0##bh' not found
YYYY-MM-DDTHH:MM:SS ERROR [vcf_dm,6a42###076a##694b4##84,c8d6] [c.v.e.s.o.model.error.ErrorFactory,dm-exec-###] [######] PUBLIC_VSP_CLUSTER_BOOTSTRAP_FAILED Failed to bootstrap VCF services runtimeYYYY-MM-DDTHH:MM:SS DEBUG [vcf_dm,6a##a7980fe###a75e###694b4784,c8d6] [c.v.e.s.c.c.v.vsphere.VcManagerBase,dm-exec-###] VM vcf-services-runtime-template-9.1.0.0.25370367 still present in inventoryYYYY-MM-DDTHH:MM:SS ERROR [vcf_dm,6a42f6###fe07###1476###4784,c8d6] [c.v.e.s.c.c.v.vsphere.VcManagerBase,dm-exec-###] VM vcf-services-runtime-template-9.1.0.0.25370367 still existsjava.lang.Exception: VM vcf-services-runtime-template-9.1.0.0.25370367 still existsCaused by: java.lang.RuntimeException: java.lang.StringIndexOutOfBoundsException: Range [-1, 0) out of bounds for length 0 at com.vmware.vcf.vimanager.services.VspServiceImpl.bootstrapVspCluster(VspServiceImpl.java:237) at com.vmware.vcf.vimanager.fsm.actions.BootstrapVspClusterVvfAction.execute(BootstrapVspClusterVvfAction.java:115) ... 15 common frames omittedCaused by: java.lang.StringIndexOutOfBoundsException: Range [-1, 0) out of bounds for length 0
VCF 9.1
This issue occurs because Distributed Resource Scheduler (DRS) is not running or is not configured for automatic placement in the target cluster. Without DRS enabled in fully automated mode, the bootstrap process cannot find a suitable host to deploy the bootstrap Virtual Machine (VM).
To resolve this issue, ensure that DRS is enabled and set to Fully Automated on the target cluster.
Log in to the vSphere Client.Select the cluster where the deployment is being performed.Navigate to Configure > Services > vSphere DRS.Click Edit.vSphere DRS is toggled ON.Set the Automation Level to Fully Automated.OK.