When upgrading VMware Cloud Foundation (VCF) from 9.0 to 9.1, the VCF Services Management Platform (VMSP) deployment fails during the "Bootstrap VCF Services Platform" step in VCF Operations.
nslookup <vCenter Server FQDN> <DNS server ip>" times out during the deployment.bootstrap_task.sh(See Additional Information), bootstrap_task_setup.log ends with below lines indicating failure to retrieve the vCenter Server SSL fingerprint:+++ openssl s_client -connect <vCenter Server FQDN>:443+++ openssl x509 -sha1 -fingerprint -noout+++ awk -F= '{ print $2 }'++ vc_fingerprint=+++ sleep 5+++ openssl s_client -connect <vCenter Server FQDN>:443+++ openssl x509 -sha1 -fingerprint -noout+++ awk -F= '{ print $2 }'++ vc_fingerprint=VMware Cloud Foundation 9.1
As the DNS server resides in a different subnet from the VCF Services Management network, the name resolution traffic must pass through a physical router.
In this particular scenario, the physical router's ARP table contains a stale MAC address entry for the bootstrap VM's IP, causing DNS reply traffic to be discarded by the virtual distributed switch which in turn causes the bootstrap VM's DNS queries to fail.
Workaround:
Permanent fix:
Engineering is aware of this issue and plans to resolve it in a future release by forcing the bootstrap VM to send a Gratuitous ARP (GARP) request during its initial boot.
To enable verbose logging for the bootstrap script:
/data/vmsp/scripts/bootstrap_task.sh in a text editor.set -euo pipefailset -exuo pipefail