Error: Live Patch cannot be performed together with live removal of VIB
search cancel

Error: Live Patch cannot be performed together with live removal of VIB

book

Article ID: 447752

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

  • In vSphere Lifecycle Manager, one or more hosts may be flagged as "Host is not compatible with the image" post compliance check or remediation attempt with message similar to below:

    Live Patch cannot be performed together with live removal of VIB(s) <vib_name>.
    Disable the 'Enforce Live Patch' remediation option and retry the operation

Cause

The Live Patch feature applies VMkernel and security updates to a running host against a cluster image without requiring a reboot or maintenance mode. This creates a conflict when the cluster image contains changes, such as the removal of a standalone VIB, that require a host reboot. The VIB is ineligible for "live removal," causing the orchestration to fail.

Resolution

To resolve this conflict, perform a standard remediation that allows a host reboot:

  1. Disable "Enforce Live Patch":
    1. In the vSphere Client, navigate to Lifecycle Manager > Settings > Remediation Settings.
    2. Under Host Settings, ensure the Enforce Live Patch option is toggled to Off.
  2. Run a Standard Remediation:
    1. Navigate to the affected Cluster or Host and select the Updates tab.
    2. Run a Pre-check to confirm which VIBs are scheduled for removal.
    3. Click Remediate.
    4. In the remediation settings, ensure the process is allowed to enter maintenance mode and reboot the host.

Workaround:

If Live Patch cannot be disabled for the entire cluster, remove the vib from the concerned host manually by following below steps:

  1. Connect to the host via SSH and run: esxcli software vib remove -n <VIB_NAME>
  2. Reboot the host.
  3. Exit maintenance mode and run the vLCM compliance scan again to verify the host is compliant.