Validation failed with the following errors: host <ESX host name>: ESXi: <ESX host name> VMKernel adapter vmotion is not assigned to a dedicated port groupThe Operations Manager component of the SDDC Manager appliance performs a compliance check against the ESX hosts' network configuration during several VCF operations, including upgrades. If this compliance check fails, the noted upgrade pre-check will fail.
Using a single vmkernel interface for both Management and vMotion traffic is against VCF best practices. See vSphere Networking Best Practices for more information.
Reconfigure the networking on all affected ESX hosts such that there are separate vmkernel network interfaces for Management and vMotion traffic.
If the reconfiguration cannot happen immediately, the following workaround can be implemented to allow the workload domain synchronization to complete:
/etc/vmware/vcf/operationsmanager/application.properties file:cp /etc/vmware/vcf/operationsmanager/application.properties /etc/vmware/vcf/operationsmanager/application.properties.bakecho "skip.assessment.external.validation.hostVmkTrafficTypeValidator=true" >> /etc/vmware/vcf/operationsmanager/application.propertiessystemctl restart operationsmanagerNote: If this workaround is implemented, work should be planned to reconfigure the ESX host networking such that it aligns with VCF best practices.