Workload domain synchronization fails in VCF 9.1. Error: VMKernel adapter vmotion is not assigned to a dedicated port group
search cancel

Workload domain synchronization fails in VCF 9.1. Error: VMKernel adapter vmotion is not assigned to a dedicated port group

book

Article ID: 447745

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VMware vSphere ESXi

Issue/Introduction

  • When attempting to synchronize a workload domain in VCF 9.1, the task fails. The error message generated is:

    Validation failed with the following errors: host <ESX host name>: ESXi: <ESX host name> VMKernel adapter vmotion is not assigned to a dedicated port group

  • This error may be present for multiple ESX hosts under the same workload domain.
  • The ESX hosts called out in the error message are configured such that they have a single vmkernel network interface for both vMotion and Management traffic types.

Environment

  • vCenter Server 9.x
  • ESX 9.x with vMotion and Management traffic types sharing a single vmkernel interface
  • VCF Operations 9.1

Cause

The Operations Manager component of the SDDC Manager appliance performs a compliance check against the ESX hosts' network configuration during several VCF operations, including upgrades. If this compliance check fails, the noted upgrade pre-check will fail.

Using a single vmkernel interface for both Management and vMotion traffic is against VCF best practices.  See vSphere Networking Best Practices for more information.

Resolution

Reconfigure the networking on all affected ESX hosts such that there are separate vmkernel network interfaces for Management and vMotion traffic.

If the reconfiguration cannot happen immediately, the following workaround can be implemented to allow the workload domain synchronization to complete:

  1. Use SSH to log in to the SDDC Manager appliance as the vcf user.
  2. Use the su command to elevate to the root account.
  3. Run the following command to create a backup copy of the /etc/vmware/vcf/operationsmanager/application.properties file:

    cp /etc/vmware/vcf/operationsmanager/application.properties /etc/vmware/vcf/operationsmanager/application.properties.bak


  4. Issue the following command to allow Operations Manager to skip the vmkernel interface validation step during an upgrade pre-chedk:

    echo "skip.assessment.external.validation.hostVmkTrafficTypeValidator=true" >> /etc/vmware/vcf/operationsmanager/application.properties

  5. Issue the following command to restart the Operations manager service:

    systemctl restart operationsmanager


  6. Wait a few minutes and then retry the domain synchronization task.

Note: If this workaround is implemented, work should be planned to reconfigure the ESX host networking such that it aligns with VCF best practices.