Smarts Integration Adapter page shows An error has occurred due to invalid configuration.
search cancel

Smarts Integration Adapter page shows An error has occurred due to invalid configuration.

book

Article ID: 447734

calendar_today

Updated On:

Products

Network Observability VMware Smart Assurance

Issue/Introduction

The Smarts Adapter credential page loads, after submitting the admin credentials it immediately gives an error message:

 

An error has occurred due to invalid configuration.  Please check your configuration settings!

Cause

The ncmsmartsadapter service fails to load necessary security components because the ncm-sso-truststore.p12 file is either inaccessible (incorrect permissions/ownership) or located at an unexpected path due to VOYENCE_HOME falling back to the default /opt/ncm instead of the actual install root.

Resolution

  1. Check if VOYENCE_HOME is set in /etc/voyence.conf
    Confirm VOYENCE_HOME is set and exported to your correct install path.
    For example:
    /opt/ncm
    If VOYENCE_HOME is missing or wrong correct it. Add:
    export VOYENCE_HOME=the_directory_you_have_ncm_installed_in

  2. Confirm the truststore actually exists at /$NCMInstall/NCMSmartsAdapter/conf/ncm-sso-truststore.p12
    If it exists confirm it has the correct permissions and user ownership.

If you had to make changes for either step 1 or 2 you will need to cycle the NCM services.