Platform Services for VMware Tanzu Platform Installation Fails with 'failed-to-parse-config' Error
search cancel

Platform Services for VMware Tanzu Platform Installation Fails with 'failed-to-parse-config' Error

book

Article ID: 447725

calendar_today

Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

During the installation of the Platform Services for VMware Tanzu Platform tile (specifically the hub-tas-agent ), the deployment fails with the following error message in the logs:

error failed-to-parse-config did not find expected key job hub-tas-agent

Environment

  • Platform Services for VMware Tanzu Platform

Cause

This issue is typically caused by an invalid character within the Ops Manager UAA admin client secret. The hub-tas-agent fails to correctly parse the configuration file because it contains unexpected or special characters that are not handled by the parser during the connection setup on the platform services tile.

The special character could be a double quote (").

Resolution

To resolve this error, you must regenerate (or assigned) the admin client secret and update the corresponding configuration in the Platform Services tile.

Step 1: Regenerate Ops Manager UAA Admin Client Secret

  1. Regenerate (or assigned) Ops Manager UAA Admin Client Secret.
  2. Confirm that no special characters are present, including double quotes.

Step 2: Refresh UAAC Client

  1. SSH into the Ops Manager VM.
  2. Delete the existing UAAC client associated with the Hub installation.
  3. Add the UAAC client again using the newly generated secret (see References)

Step 3: Update Tanzu Hub Tile

  1. From the Ops Manager Dashboard, select the Platform Services for VMware Tanzu Platform tile.
  2. Navigate to the Settings -> Connector Config.
  3. Update the password/secret field with the new regenerated secret.
  4. Save the changes.

Step 4: Apply Changes

  1. Return to the Installation Dashboard.
  2. Click Review Pending Changes.
  3. Ensure the Platform Service tile is selected and click Apply Changes.
  4. Verify that the hub-tas-agent is running.

Additional Information

Reference(s)

  • https://techdocs.broadcom.com/us/en/vmware-tanzu/platform/tanzu-hub/10-4/tnz-hub/foundations-attach-foundation-manual.html#-create-a-uaa-client