During the installation of the Platform Services for VMware Tanzu Platform tile (specifically the hub-tas-agent ), the deployment fails with the following error message in the logs:
error failed-to-parse-config did not find expected key job hub-tas-agent
This issue is typically caused by an invalid character within the Ops Manager UAA admin client secret. The hub-tas-agent fails to correctly parse the configuration file because it contains unexpected or special characters that are not handled by the parser during the connection setup on the platform services tile.
The special character could be a double quote (").
To resolve this error, you must regenerate (or assigned) the admin client secret and update the corresponding configuration in the Platform Services tile.
hub-tas-agent is running.