Error: Invalid configuration for device 0 after HCX Bulk Migration
search cancel

Error: Invalid configuration for device 0 after HCX Bulk Migration

book

Article ID: 447722

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

After migrating virtual machines using HCX Bulk Migration, the vNICs of the virtual machines are disconnected. The error "Invalid configuration for device '0'." is found in vCenter Tasks pane for "Reconfigure virtual machine" task.

Environment

VMware HCX

Cause

This issue occurs when source VMs use an outdated Virtual Machine Hardware Version that is incompatible with the destination Distributed Virtual Switch port group configuration. HCX attempts to attach the legacy vNIC backing to the modern vDS, which vCenter rejects due to parameter mismatches.

Resolution

Workaround: Follow workaround from "Invalid Configuration for Device 0" error powering on / Cloning virtual machine for virtual machines impacted post migration.

Permanent Fix: Upgrade the Virtual Machine Hardware version to a version supported by the destination environment.

  • Pre-migration: Upgrade the hardware version on the source VMs.
  • During migration: Select the "Upgrade Virtual Hardware" option within the HCX migration profile.

Additional Information

Understanding HCX Bulk Migrations