After migrating virtual machines using HCX Bulk Migration, the vNICs of the virtual machines are disconnected. The error "Invalid configuration for device '0'." is found in vCenter Tasks pane for "Reconfigure virtual machine" task.
VMware HCX
This issue occurs when source VMs use an outdated Virtual Machine Hardware Version that is incompatible with the destination Distributed Virtual Switch port group configuration. HCX attempts to attach the legacy vNIC backing to the modern vDS, which vCenter rejects due to parameter mismatches.
Workaround: Follow workaround from "Invalid Configuration for Device 0" error powering on / Cloning virtual machine for virtual machines impacted post migration.
Permanent Fix: Upgrade the Virtual Machine Hardware version to a version supported by the destination environment.