VM is onboarded with the old moref in Aria Automation once it has been cloned & deleted outside of Automation/Orchestrator
search cancel

VM is onboarded with the old moref in Aria Automation once it has been cloned & deleted outside of Automation/Orchestrator

book

Article ID: 447652

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • A VM has been cloned with the same name and the original deleted, outside of Aria Automation/Orchestrator.
  • This may happen if it has been restored by a backup solution.
  • This restored/cloned VM is then onboarded by name in an Aria Orchestrator workflow, using for example the REST API endpoint /iaas/api/machines?$filter=name%20eq%20<VM_Name>
  • This may be encountered at a later date when trying to perform actions on the onboarded VM or its resources, for example:
    • Error java.lang.IllegalStateException: Resizing the disk failed. Cause: [com.sun.xml.ws.fault.ServerSOAPFaultException: Client received SOAP Fault from server: The object 'vim.VirtualMachine:**<Old-moref>** has already been deleted or has not been completely created Please see the server log to find more detail regarding exact cause of the failure.

Environment

  • VMware Aria Automation 8.x
  • VMware Aria Orchestrator 8.x

Cause

The workflow onboards the VM by name, which is the same in the deleted VM as the restored VM
The workflow waits for the next data collection cycle, but this does not guarantee that Aria Automation has only a record of the new VM for onboarding

Resolution

Approaches to ensure the correct VM is onboarded include:

  • Checking that the moref of the VM has changed before onboarding it
  • Onboard the VM by an identifier other than its name