ESXi host failed NSX installation and reported the following error in the NSX Manager UI:
"Failed to manage NSX optional services on the host. Error: Cannot invoke "String.equalsIgnoreCase(String)" because the return value of "com.vmware.vim.binding.vmodl.MethodName.getName()" is null
The NSX Manager system log ( /var/log/syslog ) contains the following error message:
ERROR NSX #### [nsx@4413 comp="nsx-manager" errorCode="MP26046" level="ERROR" logger="ManageLicensedServiceActivity"] Failed to manage DFW optional services: [nsx-scx] on the host ####. Runtime Error: Cannot invoke "String.equalsIgnoreCase(String)" because the return value of "com.vmware.vim.binding.vmodl.MethodName.getName()" is null
WARNING NSX 10320 [nsx@4413 comp="nsx-manager" level="WARNING" logger="NticsCloudCacheClientServiceImpl" msgID="POLICY" subcomp="manager" threadName="IP_REPUTATION_FEED_DOWNLOAD_TASK-0"] User cannot access the vDefend Threat Intelligence Service API with given license. ServerErrorCode: 100003. ErrorMessage: The license is invalid or expired.
ERROR NSX #### [nsx@4413 comp="nsx-manager" errorCode="PM523713" level="ERROR" logger="NticsClientServiceImpl"] REST API failed while getting IP reputation feed due to unknown exception - com.vmware.nsx.management.container.exceptions.LicenseViolationException: This feature is not supported with the current applied license.
VMware NSX
This issue occurs when optional security services such as DFW, IDS/IPS, or URL Filtering are enabled on a cluster, but the required add-on licenses for these features are either expired or have not been installed.
Verified the VCF license on the NSX Manager by navigating to System > Licenses.
You can click on the impacted hosts and select Resolve to remediate the error directly from the NSX Manager UI.
Please refer to KB 390536 and the vDefend Firewall Prerequisites technical documentation for more ANS license information.