Unable to start connectall-broker service after installation on Red Hat Enterprise Linux.
Command- systemctl start connectall-broker
Error- Job for connectall-broker service failed because the control process exited with error code.See "systemctl status connectall-broker.service" and "journalctl -xeu connectall-broker.service" for details.
4.2.x
When you move files around, install custom binaries, or copy application files into a new directory, they often inherit incorrect SELinux labels. If the labels are wrong, SELinux will block the system or application from executing those files, leading to "Permission Denied" errors—even if your traditional Linux permissions (chmod/chown) are completely correct.
Running below command ensures that your broker's binary files have the correct security labels so the system allows them to run without being blocked.
Execute below command and try to start broker service followed by other services.
restorecon -Rv /opt/apps/ConnectALL/Broker/connectall-broker/bin/artemis-service