[CERTIFICATE] Replace cert Failed: Exception foundVecsException occurred.Caught exception Native platform error [code: 90023]Adding VecsEntryType.CERT_ENTRY_TYPE_PRIVATE_KEY entry into store 'BACKUP_STORE' failed.[Server: __localhost__, User: __localuser__]Error while replacing Machine SSL CertError in creating a new entry for bkp___MACHINE_CERTin VECS Store BACKUP_STOREvCenter Server 8.0
As of vCenter 8.0, vSphere does not support generating ECDSA certificates. VECS enforces this by preventing any new entries being created using certificates based on ECDSA.
As part of the replacement process through vSphere UI or certificate-manager, a backup of the current certificate is created in a backup store in VECS.
If the machine_ssl_cert has an ECDSA based certificate, this backup entry is rejected by VECS, causing the error.
Replace machine_ssl_cert manually with a dummy entry that is compliant with VECS.
/usr/lib/vmware-vmafd/bin/vecs-cli entry list --store machine --text | grep "Signature Algorithm"/usr/lib/vmware-vmafd/bin/vecs-cli entry getcert --store machine --alias machine --output /root/dummy.crt/usr/lib/vmware-vmafd/bin/vecs-cli entry getkey --store machine --alias machine --output /root/dummy.key/usr/lib/vmware-vmafd/bin/vecs-cli entry delete --store machine_ssl_cert --alias __MACHINE_CERT /usr/lib/vmware-vmafd/bin/vecs-cli entry create --store machine_ssl_cert --alias __MACHINE_CERT --cert /root/dummy.crt --key /root/dummy.key