Error: "Initial Sync Failed Unable to create dummy disk, A specified parameter was not correct" - Bulk Migration Failure
search cancel

Error: "Initial Sync Failed Unable to create dummy disk, A specified parameter was not correct" - Bulk Migration Failure

book

Article ID: 447446

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Bulk Migration failed with an error.
  • Migration was started with "Datastore default Storage Policy" selected.
  • the following error was displayed in the HCX GUI:
    Initial Sync Failed Unable to create dummy disk, A specified parameter was not correct:
  • The following error is displayed in the tasks on the destination vCenter Server:
     HCX Bulk Migration Failed. Unable to create dummy disk, A specified parameter was not correct:
  • On the destination HCX Manager, messages starting with text like the following are displayed in the app.log:
    <TIMESTAMP> UTC [ReplicationTransferService_SvcThread-258, Ent: HybridityAdmin, , TxId: TxId: <TxID>] WARN  c.v.h.s.r.jobs.SetupTarget- Unable to create dummy disk. Task Response - (vim.TaskInfo) {
       dynamicType = null,
       dynamicProperty = null,
       key = <taskID>,
       task = ManagedObjectReference: type = Task, value = <taskID>, serverGuid = null,
       description = null,
       name = CreateVirtualDisk_Task,
       descriptionId = VirtualDiskManager.createVirtualDisk,
       entity = null,
       entityName = ,
       locked = null,
       state = error,
       cancelled = false,
       cancelable = false,
       error = (vmodl.fault.InvalidArgument) {
          faultCause = null,
          faultMessage = null,
          invalidProperty = null
       },
       result = null,
       progress = null,
       reason = (vim.TaskReasonUser) {
          dynamicType = null,
          dynamicProperty = null,
          userName = <UserName>
       },
       ...

Environment

VMware HCX

Cause

When migrating an unencrypted virtual machine, the error is caused by encryption being enabled in the default storage policy of the target datastore.

Resolution

Select a storage policy with encryption disabled using the following steps:

  1. Open the Mobility Group edit dialog.
  2. Select the target datastore.
  3. Under "Select Storage Profile", select a storage profile with encryption not enabled.

Additional Information

Create a VM Storage Policy for Host-Based Data Services

If you have any questions, open a case with Broadcom Support.: Creating and managing Broadcom support cases.