HCXを使用したBulk Migrationによる仮想マシンの移行が「 Failed to run SOAP request CreateDirectory Cannot complete file creation operation.」で失敗する
search cancel

HCXを使用したBulk Migrationによる仮想マシンの移行が「 Failed to run SOAP request CreateDirectory Cannot complete file creation operation.」で失敗する

book

Article ID: 447443

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

免責事項:これは英文の記事「Error: "Initial Sync Failed Unable to create dummy disk, A specified parameter was not correct" - Bulk Migration Failure」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • Bulk Migrationがエラーで失敗しました
  • 「Datastore default Storage Policy」を選択して移行を開始しました
  • 移行失敗後にHCXのGUIには以下のエラーが表示されています
    Initial Sync Failed Unable to create dummy disk, A specified parameter was not correct:
  • 移行先のvCenter Server のタスクには以下のエラーが記録されています
     HCX Bulk Migration Failed. Unable to create dummy disk, A specified parameter was not correct:
  • 移行先のHCX Manager のapp.log には以下のような文言ではじまるメッセージが記録されています
    <TIMESTAMP> UTC [ReplicationTransferService_SvcThread-258, Ent: HybridityAdmin, , TxId: TxId: <TxID>] WARN  c.v.h.s.r.jobs.SetupTarget- Unable to create dummy disk. Task Response - (vim.TaskInfo) {
       dynamicType = null,
       dynamicProperty = null,
       key = <taskID>,
       task = ManagedObjectReference: type = Task, value = <taskID>, serverGuid = null,
       description = null,
       name = CreateVirtualDisk_Task,
       descriptionId = VirtualDiskManager.createVirtualDisk,
       entity = null,
       entityName = ,
       locked = null,
       state = error,
       cancelled = false,
       cancelable = false,
       error = (vmodl.fault.InvalidArgument) {
          faultCause = null,
          faultMessage = null,
          invalidProperty = null
       },
       result = null,
       progress = null,
       reason = (vim.TaskReasonUser) {
          dynamicType = null,
          dynamicProperty = null,
          userName = <UserName>
       },
       ...

Environment

VMware HCX

Cause

暗号化されていない仮想マシンの移行時に、ターゲットのデータストアのデフォルトのストレージプロファイルで暗号化が有効になっていることでエラーが発生しています。

Resolution

以下のような手順で暗号化が無効なストレージプロファイルを選んでください。

  1. Mobility Groupの編集画面を開きます。
  2. データストアの選択画面を開きます
  3. "Select Storage Profile"の項目で暗号化が無効なストレージプロファイルを選択します。

Additional Information

ホストベースのデータ サービスの仮想マシン ストレージ ポリシーの作成


ご不明な点がある場合には、Broadcomサポートにお問い合わせください.: Creating and managing Broadcom support cases.