Connection between the NSX Native load balancer service and the Tier-1 gateway fails with error code 502094.
search cancel

Connection between the NSX Native load balancer service and the Tier-1 gateway fails with error code 502094.

book

Article ID: 447441

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Attempts to connect the load balancer service to the Tier-1 gateway via the NSX Manager UI fail.

  • The HA mode of the target Tier-1 gateway is configured as "Distributed Only".

  • The following error is recorded in /var/log/proton/nsxapi.log on the NSX Manager when the issue occurs:
YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 ConnectivityValidationUtils 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM503099" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] Locale services need to be created for router /infra/tier-1s/{{TIER1_NAME}}, with edge clusters
YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 LbServiceServiceImpl 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM502094" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] The tier-1 /infra/tier-1s/{{TIER1_NAME}} does not have associated edge cluster to deploy a load balancer service /infra/lb-services/{{LB_SERVICE_ID}}.
YYYY-MM-DDTHH:MM:SS.NNNZ ERROR http-nio-127.0.0.1-7440-exec-9 LbServiceServiceImpl 79847 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM502001" level="ERROR" reqId="{{UUID}}" subcomp="manager" username="admin"] Errors {"moduleName":"policy","errorCode":502094,"errorMessage":"The tier-1 /infra/tier-1s/{{TIER1_NAME}} does not have associated edge cluster to deploy a load balancer service /infra/lb-services/{{LB_SERVICE_ID}}."} validating LbService /infra/lb-services/{{LB_SERVICE_ID}}

Environment

VMware NSX

Cause

This is the expected behavior.
The destination tier-1 gateway must be in the Active-Standby mode.

Resolution

Follow the procedure below to modify the Tier-1 gateway's HA mode and assign an Edge cluster.

  1. Log in to the NSX Manager UI.
  2. Navigate to Networking > Tier-1 Gateways.
  3. Locate the Tier-1 Gateway hosting the load balancer service, click the vertical ellipsis, and select Edit.
  4. In the HA Mode drop-down menu, select the "Active Standby"
  5. In the Edge Cluster drop-down menu, select the new target Edge Cluster.
  6. Ensure the Edge Pool Allocation Size remains correctly sized for your deployed load balancer (e.g., LB Small, LB Medium).
  7. Click Save to apply the configuration.
  8. Navigate to Networking > Load Balancing.
  9. Locate the Load balancer service, click the vertical ellipsis, and select Edit.
  10. In the Attachment drop-down menu, select the Tier-1 Gateway hosting the load balancer service.
  11. Click Save to apply the configuration.

Additional Information