Failed to fetch association information for profile error occurs when restoring a VM with Cohesity to VMware Cloud Director
search cancel

Failed to fetch association information for profile error occurs when restoring a VM with Cohesity to VMware Cloud Director

book

Article ID: 447381

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Restoring a virtual machine using Cohesity appears to complete successfully and the restored item works without issue.
  • The temporary storage policy created policy created by Cohesity is still present in both vCenter and VMware Cloud Director after the restoration completes.
  • The restoration results in the following error in Cohesity:

    Failed to fetch association information for profile (pbm.profile.ProfileId) { dynamicType = null, dynamicProperty = null, uniqueId = ########-####-####-####-############ } and entity type null.

  • At the time of the failure, an error similar to following can be found in the vCenter sps.log:

    2026-06-15T14:24:25.095Z [pool-4-thread-18] ERROR opId=########-####-####-####-############ com.vmware.pbm.persistence.impl.AssociationPersistenceManagerImpl - Failed to fetch association information for profile (pbm.profile.ProfileId) {
       dynamicType = null,
       dynamicProperty = null,
       uniqueId = ########-####-####-####-############
    } and entity type null
    java.util.concurrent.ExecutionException: com.vmware.vim.sms.fault.VasaServiceException: java.util.concurrent.ExecutionException: com.vmware.vim.vmomi.client.common.UnexpectedStatusCodeException: Unexpected status code: 503
    ...

  • The vsan-health service is not running or is not in a healthy state.

Environment

VMware Cloud Director 10.6.x

Cause

There are dependencies between the sps service (i.e., the storage profile service, which is utilized during the Cohesity restoration process) and the vsan-health service, which can result in the errors noted if this service is unavailable. This does not require the use of vSAN in the environment, since the vsan-health service can be used, even if vSAN is not implemented.

Resolution

In order to remediate this behavior, complete the following steps:

  1. Perform the following on the vCenter to confirm if the vsan-health service is running:

    vmon-cli -s vsan-health

  2. If it isn't running, restart it:

    vmon-cli -r vsan-health

  3. Once it is successfully running, restart the sps service:

    vmon-cli -r sps

  4. After both services appear to be healthy and online, test the restoration process.