Upgraded the cloud proxy to version 26.6.1.24, and after the upgrade we are not able to start the service using the script (apmservices.cloudproxy.sh).
Upon checking the logs we are receiving a number of errors including:
ERROR 746149 --- [cloudproxy] [main] o.s.os.linux.LinuxOperatingSystem : Did not JNA classes. Investigate incompatible version or missing native dll.
ERROR 746149 --- [cloudproxy] [main] o.s.boot.SpringApplication : Application run failed
org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'cloudProxyServer': Unsatisfied dependency expressed through field 'supportability': Error creating bean with name 'cloudProxySupportability': Invocation of init method failed
Caused by: java.lang.ExceptionInInitializerError: Exception java.lang.UnsatisfiedLinkError: Failed to create temporary file for /com/sun/jna/linux-x86-64/libjnidispatch.so library: No space left on device [in thread "main"]
When checking the available disk space where the cloud proxy files are there is plenty of space available:
Identified a configuration fix in the customer's apmservices.cloudproxy.sh script for this service startup issue by adding "-Djna.tmpdir=<tempdir location>" to the APM_JAVA_OPTS parameter list for the JVM startup parameters. This helps to ensure the new version of JNA library to use in the specified tmp directory instead of the system default one, which triggered the original issue reported by this customer.
Also possibly set in APM_JAVA_OPTS, -Djava.io.tmpdir=<tempdir location>.