AKO Pod Crashing with HTTP 400 Error Post Avi Controller Upgrade
search cancel

AKO Pod Crashing with HTTP 400 Error Post Avi Controller Upgrade

book

Article ID: 447359

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • After upgrading the Avi Controller, the Avi Kubernetes Operator (AKO) operator enters a crash loop.
  • The AKO pod status shows CrashLoopBackOff. Reference output below: 

#kubectl get pods -n vmware-system-ako

NAME                                                READY                    STATUS            RESTARTS       AGE

vmware-system-ako-ako-controller-manager-<>-<>      0/1                      CrashLoopBackOff   <>            <>

  • The AKO logs display the following error:

Encountered an error on GET request to URL https://<Avi-IP>:<port>//api/network/?include_name=page_size=100&name.in=<Network Name> HTTP code: 400

Environment

Avi Load balancer version 30.x and later

vCenter version 8.0.3

Cause

The issue is caused due to an incompatibility between supervisor and Avi in handling objects having "space" character present. 

Resolution

Workaround: 

  • Rename the network name such that there is no space in the network name for which the error is seen in AKO logs.

Fix: 

  • This issue is resolved in vCenter 8.0.3I. Upgrading to this version or a later release is recommended to address the underlying compatibility issue.