Error: Missing depot service when installing Supervisor Services in VCF 9.1
search cancel

Error: Missing depot service when installing Supervisor Services in VCF 9.1

book

Article ID: 447329

calendar_today

Updated On:

Products

VMware vSphere Kubernetes Service VCF Operations/Automation (formerly VMware Aria Suite) VMware Cloud Foundation

Issue/Introduction

When attempting to install Supervisor Services, from the vCenter Server, the deployment fails with an error indicating the depot service is missing. Verifying the Supervisor cluster confirms that the depot.kube-system.svc service does not exist. Software Depot is in Connection Mode equals Connected.

Supervisor encountered an error while trying to reach the container image registry hosting Service Version 1.1.0-25100889 and its signatures cannot be verified: Connectivity to image depot.kube-system.svc/vcf/vcf-service-argoc d/ga/1.1.0/argocd-service:v1.1.0_vmware.1 cannot be verified: Get "https://depot.kube-system.svc/v2/": dial tcp: look up depot.kube-system.svc on 127.0.0.53:53: no such host Please check that the container image registry is configured properly and can be reached from the Supervisor's network.

Environment

  • VMware Cloud Foundation 9.1
  • VMware vSphere Kubernetes Service

Cause

The depot.kube-system.svc service is deployed and managed by the Regional Harbor service. If the VCF Service Harbor has not been deployed first via VCF Automation (VCFA), the required depot service will not be present on the Supervisor cluster, preventing the successful installation of other Supervisor Services from vCenter Server.

Resolution

 

  1. Log in to the VCF Automation (VCFA) Provider interface.
  2. Navigate to Service Management > VCF Services.
  3. Deploy the VCF Service Harbor.
  4. Allow the installation to complete and verify that the depot.kube-system.svc service is successfully created and routable for the Supervisor.
  5. Once the depot service is verified as running, proceed to install the desired Supervisor Services directly from vCenter Server.

 

Additional Information

Configure a Software Depot Connection Mode