When attempting to install Supervisor Services, from the vCenter Server, the deployment fails with an error indicating the depot service is missing. Verifying the Supervisor cluster confirms that the depot.kube-system.svc service does not exist. Software Depot is in Connection Mode equals Connected.
Supervisor encountered an error while trying to reach the container image registry hosting Service Version 1.1.0-25100889 and its signatures cannot be verified: Connectivity to image depot.kube-system.svc/vcf/vcf-service-argoc d/ga/1.1.0/argocd-service:v1.1.0_vmware.1 cannot be verified: Get "https://depot.kube-system.svc/v2/": dial tcp: look up depot.kube-system.svc on 127.0.0.53:53: no such host Please check that the container image registry is configured properly and can be reached from the Supervisor's network.
The depot.kube-system.svc service is deployed and managed by the Regional Harbor service. If the VCF Service Harbor has not been deployed first via VCF Automation (VCFA), the required depot service will not be present on the Supervisor cluster, preventing the successful installation of other Supervisor Services from vCenter Server.
depot.kube-system.svc service is successfully created and routable for the Supervisor.