When an ESXi host is prepared for NSX or an upgrade to existing NSX VIBs is attempted, the following symptoms may be observed:
nc -zv <NSX Manager IP> 443
nc: connect to <NSX Manager IP> port 443 (tcp) failed: Connection timed out
nsxcli commands run from the host may fail with an error similar to "Unable to connect to the API service" or return no results, for example:push host certificate <NSX Manager IP> username admin thumbprint <thumbprint> password <password>% Push certificate failed: 'Unable to connect to the API service'get controllers<date> Controller IP Port SSL Status Is Physical Master Session State Controller FQDN Failure ReasonThis issue can occur for one of the following scenarios:
nc or curl may fail even if the physical network path is open.Unable to connect to TCP ports 443,1234 and 1235 from ESXi host to NSX manager can be used to help diagnose/troubleshoot this issue.
The issue noted in NSX Host Software Installation fails with alert “Failed to install software on host. Time out waiting for host to join NSX Manager" during VCF import of a brownfield environment on some hosts may be occurring in a VCF 9.x environment if there is no issue with port connectivity between the ESX hosts and the NSX Manager nodes.
Reference VMware Ports and Protocols for full details on required port connectivity for NSX.