When performing an unstretch operation on a vSAN Stretched Cluster, attempting to place a host into Maintenance Mode with Full Data Migration fails.
"Resource Check Failed - internal failure happening during the resource check. Please check clomd.log..."
Placing the host in Maintenance mode with Ensure Accessibility may show stretched VM Templates that are unable to evacuate data from the node
ESXi 8.x
This issue occurs if VM templates or unassociated objects (objects that are not currently registered in the inventory) still leverage a Stretched Cluster Storage Policy (e.g., Dual Site Mirroring) assigned.
To resolve this issue, ensure all objects, including templates, are compliant with a non-stretched policy: