vSAN host Maintenance Mode "Resource Check Failed" unstretch
search cancel

vSAN host Maintenance Mode "Resource Check Failed" unstretch

book

Article ID: 447311

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

When performing an unstretch operation on a vSAN Stretched Cluster, attempting to place a host into Maintenance Mode with Full Data Migration fails. 

"Resource Check Failed - internal failure happening during the resource check. Please check clomd.log..."

Placing the host in Maintenance mode with Ensure Accessibility may show stretched VM Templates that are unable to evacuate data from the node

Environment

ESXi 8.x

Cause

This issue occurs if VM templates or unassociated objects (objects that are not currently registered in the inventory) still leverage a Stretched Cluster Storage Policy (e.g., Dual Site Mirroring) assigned. 

Resolution

To resolve this issue, ensure all objects, including templates, are compliant with a non-stretched policy:

  • Identify Templates:  Check the VMs and Templates view in vCenter. Ensure all templates have their storage policy updated to a standard cluster policy (e.g., Site Disaster Tolerance = None).

    Verify Unassociated Objects: To identify any orphaned or unassociated objects on the vSAN datastore that may still carry the stretched policy Procedures for identifying Unassociated vSAN objects..

  • Check Compliance: Navigate to Cluster > Monitor > vSAN > Virtual Objects and verify that all objects show as Healthy and Compliant.

  • Retry Maintenance Mode: Once all objects are updated, re-attempt to place the host into Maintenance Mode.