Error: "Initial Sync Failed Migration Job ReplicationTransferJob, subworkflow PushCryptoSpecToTargetHosts failed." when Bulk Migration an encrypted virtual machine
search cancel

Error: "Initial Sync Failed Migration Job ReplicationTransferJob, subworkflow PushCryptoSpecToTargetHosts failed." when Bulk Migration an encrypted virtual machine

book

Article ID: 447283

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Bulk Migration of the encrypted virtual machine failed with the following error:
    Initial Sync Failed Migration Job ReplicationTransferJob, subworkflow PushCryptoSpecToTargetHosts failed.
  • The following error is logged in the HCX Manager app.log:
    <TIMESTAMP> UTC [ReplicationTransferService_SvcThread-40, Ent: DEFAULT, , TxId: TxId: <TxID>] ERROR c.v.h.s.r.j.PushCryptoSpecToTargetHostJob- Error occurred while pushing crypto specs to target host <hostID> for migrationId <Migration ID>
    com.vmware.vchs.hybridity.adapters.vsphere.vim.SOAPFaultException: Failed to run SOAP request ConfigureCryptoKey RuntimeFault.summary
            at com.vmware.vchs.hybridity.adapters.vsphere.vim.Connection.executeVimRequest(Connection.java:444)
            at com.vmware.vchs.hybridity.adapters.vsphere.vim.HostSystem.configureCryptoKeys(HostSystem.java:62)
            at com.vmware.hybridity.service.replicationtransfer.ReplicationTransferService.ensureHostIsInCryptoSafeMode(ReplicationTransferService.java:1541)
            at com.vmware.hybridity.service.replicationtransfer.jobs.PushCryptoSpecToTargetHostJob.doPushCryptoSpecToHost(PushCryptoSpecToTargetHostJob.java:78)
            at com.vmware.hybridity.service.replicationtransfer.jobs.PushCryptoSpecToTargetHostJob.run(PushCryptoSpecToTargetHostJob.java:47)
            at com.vmware.vchs.hybridity.messaging.LoggingJobWrapper.run(LoggingJobWrapper.java:41)
            at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
            at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
            at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
            at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
            at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
            at java.base/java.lang.Thread.run(Thread.java:829)

Environment

VMware HCX

Cause

The issue is caused by the Native Key Provider not being configured correctly on the target vCenter Server.

Resolution

Set the target key provider as the default using the following steps:

  1. Log in to the vCenter Server system with the vSphere Client.
  2. Browse the inventory list and select the vCenter Server instance.
  3. Click Configure, and under Security click Key Providers.
  4. Select the target key provider and click [SET AS DEFAULT].
  5. Click [SET AS DEFAULT] again in the confirmation dialog.

Additional Information

Configure a vSphere Native Key Provider