Internal server error /opt/vmware/vcloud-director/logs/vcloud-container-debug.log on one of the VCD cells you can see entries similar to:com.vmware.vcloud.api.presentation.service.InternalServerErrorException: Internal Server Error at com.vmware.vcloud.common.future.FutureUtil.convertExecutionException(FutureUtil.java:264) at com.vmware.vcloud.common.future.FutureUtil.waitForFuture(FutureUtil.java:129) at com.vmware.ssdc.backend.services.impl.VmManagerImpl.performRelocateVmDuringReconfigure(VmManagerImpl.java:3495)...Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.getResourcePoolInfo(GenericVirtualResourcePool.java:1613) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.computeResourcePoolConfig(GenericVirtualResourcePool.java:1994) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.computeAndAdjustDelta(GenericVirtualResourcePool.java:4466) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePools(GenericVirtualResourcePool.java:1467) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$ReconfigOtherResourcePoolRunnableContext.run(GenericVirtualResourcePool.java:5166) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$ReconfigOtherResourcePoolRunnableContext.run(GenericVirtualResourcePool.java:5149) at com.vmware.vcloud.common.persist.ConversationContextExecutor.execute(ConversationContextExecutor.java:67) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$3.run(GenericVirtualResourcePool.java:4576) at com.vmware.vcloud.common.persist.ConversationFactoryImpl.executeIsolated(ConversationFactoryImpl.java:371) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.executeRunnableContext(GenericVirtualResourcePool.java:4566) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.executeRunnableContext(GenericVirtualResourcePool.java:4559) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePoolsInVRP(GenericVirtualResourcePool.java:5202) at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePoolsInVRP(GenericVirtualResourcePool.java:5193) at com.vmware.ssdc.backend.services.impl.RelocateVmActivity$ConfigureSourceHubIfNeeded.invoke(RelocateVmActivity.java:1097)VMware Cloud Director 10.6
When trying to allocate the resources requested VCD creates Resource pools that fail to create in vCenter and then are not deleted in VCD.
This is a known issue affecting VMware Cloud Director 10.6.
Currently there is no resolution.
To workaround this issue you need to provision the organization VDC in a way that doesn't over commit the PVDC.
This issue leaves stale entries in VCD causing the issue Error: "Internal Server Error" and "Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException" when interacting with an Organization VDC
If you already have had this issue you will need delete the stale entries.
To resolve this issue, contact Broadcom Support and note this Article ID (447145) in the problem description. For more information, see Creating and managing Broadcom support cases.