Error: "Internal server error" when modifying the Allocation Model Settings of an Organization VDC
search cancel

Error: "Internal server error" when modifying the Allocation Model Settings of an Organization VDC

book

Article ID: 447145

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When you try to change the Organization VDC allocation in VMware Cloud Director (VCD) you get an error:

    Internal server error 

  • You're trying to over-provision the OVDC over the real capacities of the Provider VDC.
  • The Organization VDC has elasticity enabled and Flex allocation model.
  • In /opt/vmware/vcloud-director/logs/vcloud-container-debug.log on one of the VCD cells you can see entries similar to:

    com.vmware.vcloud.api.presentation.service.InternalServerErrorException: Internal Server Error
     at com.vmware.vcloud.common.future.FutureUtil.convertExecutionException(FutureUtil.java:264)
     at com.vmware.vcloud.common.future.FutureUtil.waitForFuture(FutureUtil.java:129)
     at com.vmware.ssdc.backend.services.impl.VmManagerImpl.performRelocateVmDuringReconfigure(VmManagerImpl.java:3495)
    ...
    Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.getResourcePoolInfo(GenericVirtualResourcePool.java:1613)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.computeResourcePoolConfig(GenericVirtualResourcePool.java:1994)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.computeAndAdjustDelta(GenericVirtualResourcePool.java:4466)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePools(GenericVirtualResourcePool.java:1467)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$ReconfigOtherResourcePoolRunnableContext.run(GenericVirtualResourcePool.java:5166)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$ReconfigOtherResourcePoolRunnableContext.run(GenericVirtualResourcePool.java:5149)
     at com.vmware.vcloud.common.persist.ConversationContextExecutor.execute(ConversationContextExecutor.java:67)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool$3.run(GenericVirtualResourcePool.java:4576)
     at com.vmware.vcloud.common.persist.ConversationFactoryImpl.executeIsolated(ConversationFactoryImpl.java:371)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.executeRunnableContext(GenericVirtualResourcePool.java:4566)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.executeRunnableContext(GenericVirtualResourcePool.java:4559)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePoolsInVRP(GenericVirtualResourcePool.java:5202)
     at com.vmware.vcloud.fabric.compute.vrp.GenericVirtualResourcePool.reconfigureOtherResourcePoolsInVRP(GenericVirtualResourcePool.java:5193)
     at com.vmware.ssdc.backend.services.impl.RelocateVmActivity$ConfigureSourceHubIfNeeded.invoke(RelocateVmActivity.java:1097)

  • You added one or more clusters to the Provider VDC after creating the Organization VDC.

Environment

VMware Cloud Director 10.6

Cause

When trying to allocate the resources requested VCD creates Resource pools that fail to create in vCenter and then are not deleted in VCD.

 

Resolution

This is a known issue affecting VMware Cloud Director 10.6. 

Currently there is no resolution.

Workaround

To workaround this issue you need to provision the organization VDC in a way that doesn't over commit the PVDC.

Additional Information

This issue leaves stale entries in VCD causing the issue Error: "Internal Server Error" and "Caused by: com.vmware.vcloud.fabric.compute.ResourcePoolNotFoundException" when interacting with an Organization VDC 

If you already have had this issue you will need delete the stale entries.

To resolve this issue, contact Broadcom Support and note this Article ID (447145) in the problem description. For more information, see Creating and managing Broadcom support cases.