UI inaccessible due to incorrect DNS configuration - VMware Cloud Foundation (VCF) Operations
search cancel

UI inaccessible due to incorrect DNS configuration - VMware Cloud Foundation (VCF) Operations

book

Article ID: 447093

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Unable to access the VCF Operations user interface.
  • The Admin interface indicates that nodes are inaccessible.
  • Unable to connect to the configured DNS server from the VCF Operations nodes (via ping or Telnet)
  • Unable to bring the VCF Operations cluster fully online.

Environment

VCF Operations

Resolution

  1. Take the VMware Cloud Foundation Operations node(s) offline manually:
    1. Log in to each VCF Operations node via SSH as root.
    2. Run the following command on every node to bring the slice offline:
      $VMWARE_PYTHON_BIN $VCOPS_BASE/../vmware-vcopssuite/utilities/sliceConfiguration/bin/vcopsConfigureRoles.py --action bringSliceOffline --offlineReason "Maintenance"
  2. On all nodes, execute the following block to stop the CaSA service, back up the database script, and force the state to OFFLINE:
    service vmware-casa stop; sleep 10;cp /storage/db/casa/webapp/hsqldb/casa.db.script /storage/db/casa/webapp/hsqldb/casa.db.script.backup;sed -ri 's/"onlineState":"\w+"/"onlineState":"OFFLINE"/g;s/"initialization_state":"\w+"/"initialization_state":"NONE"/g;s/"online_state":"\w+"/"online_state":"OFFLINE"/g;s/"online_state_reason":"\w+"/"online_state_reason":""/g;s/"remove_node_state":"\w+"/"remove_node_state":"NONE"/g;s/"installation_state":"\w+"/"installation_state":"DONE"/g' /storage/db/casa/webapp/hsqldb/casa.db.script;sleep 2; service vmware-casa start;
  3. Take a memory-free snapshot of all nodes (Primary, Replica, Data, and Cloud Proxies)
    Snapshot Creation in VMware Aria Operations
  4. Power off all VCF Operations appliances within the vCenter inventory.
  5. For each node, navigate to the Configure tab > vApp Options.
  6. Locate the DNS property in the list.
  7. Update the value to the correct DNS server address.
  8. Power on all VCF Ops nodes and bring the VCF Ops cluster online.

Additional Information

Reconfigure DNS and Domain Search on VCF Operations Nodes for Site Protection and Disaster Recovery for VMware Cloud Foundation