Enhanced Replication Mappings report error: "Fault occurred while performing health check. Details: 'Connect: Connection timed out'."
vSphere Replication
Live Recovery
The replication failure is likely caused by an MTU mismatch between the vmknics and Distributed Virtual Switches on the source and target sites
For replication to function properly, the configuration must be consistent end-to-end (either 1500 or 9000 across the board).