免責事項: これは英文の記事VM operations hang due to expired VSM service account passwordの日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事を参照してください。
vCenter Server 8.x において、仮想マシンの操作を実行しようとすると、操作がハングアップし、不明な時間の経過後に完了するか、または完了に失敗します。
Failed to clone state for the entity '<VM_Template_Name>' on extension vService Manager
vCenter の vsm.log (/var/log/vmware/vsm/vsm.log) に以下のエラーが記録されます。:
[timestamp] INFO [Thread-4] ServiceUtil.java 137 - Acquiring SAML token for user vmware-vsm-########-####-####-####-########@example.domain [timestamp] ERROR [Thread-4] SoapBindingImpl.java 185 - SOAP faultcom.sun.xml.internal.ws.fault.ServerSOAPFaultException: Client received SOAP Fault from server: Password of the user logging on is expired. :: Password of the user logging on is expired. :: User account expired: {Name: vmware-vsm-########-####-####-####-########, Domain: example.domain} Please see the server log to find more detail regarding exact cause of the failure...com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl$RequestResponseProcessor.sendRequest(SecurityTokenServiceImpl.java:983) [libwstclient.jar:?] at com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl$RequestResponseProcessor.executeRoundtrip(SecurityTokenServiceImpl.java:902) [libwstclient.jar:?] at com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl.acquireToken(SecurityTokenServiceImpl.java:155) [libwstclient.jar:?] at com.vmware.vsm.utils.ServiceUtil.getSamlTokenForSvcAccount(ServiceUtil.java:138) [vsm.jar:?] at com.vmware.vsm.vc.VCenterListener.loadSamlTokenAndPrivateKey(VCenterListener.java:473) [vsm.jar:?] at com.vmware.vsm.vc.VCenterListener.initializeConnection(VCenterListener.java:268) [vsm.jar:?] at com.vmware.vsm.vc.VCenterListener.run(VCenterListener.java:301) [vsm.jar:?][timestamp] INFO [Thread-4] ServiceUtil.java 142 - Password expired. Resetting service account password
[timestamp] info vpxd[27763] [Originator@6876 sub=VmProv opID=TxId: ########-####-####-####-########51b0-47-01] Powering on VM '[vsanDatastore] ########-####-####-####-########/Interconnect-##-IX-##.vmx' on host <host fqdn/ip>[timestamp] warning vpxd[27763] [Originator@6876 sub=vmomi.soapStub[258] opID=TxId: ########-####-####-####-#######51b0-47-01] SOAP request returned HTTP failure; <<io_obj p:0x00007fdab0421b10, h:182, <TCP '127.0.0.1 : 37532'>, <TCP '127.0.0.1 : 15007'>>, /vsm/ovfConsumer/>, method: notifyPowerOn; code: 500(Internal Server Error)[timestamp] info vpxd[27763] [Originator@6876 sub=OvfConsumers opID=TxId: ########-####-####-####-########] Failed to invoke OVF stub adapter, will re-try after login; N5Vmomi5Fault13SecurityError9ExceptionE(Fault cause: vmodl.fault.SecurityError--> )--> [context]zKq7AVECAQAAAIUcWQEsdnB4ZAAAxbVTbGlidm1hY29yZS5zbwAAUglDAIwxRACaSEsBoy8XbGlidm1vbWkuc28AAX6eJQFZICABOk4gAZ3HH4JJ8TUBdnB4ZACCscNFAoKExUUCAX02GoNhyScBbGlidmltLXR5cGVzLnNvAIJGprsBgrXTuwGCNIHUAYLM9SACgn+wGwKC670kAoJI3SQCgkr9JAKCfQhiAoLPGGICgvkvYQKCUothAoLJH9QBgk0M1QGChw3VAYJTDtUBgrIO1QGD5v4xAYK5d2MCAdXDG4IgokMCgn0IYgKCzxhiAoL5L2ECgpQCYgIA5ss3APkkOACTwFEEro4AbGlicHRocmVhZC5zby4wAAUv3g9saWJjLnNvLjYA[/context]
[timestamp] ERROR [pool-5-thread-1] VsmActivationValidator.java 267 - Failed to validate user: only vpxd-svc-acct requests allowed and not
A general system error occurred:The import of library item <item id> has failed. Reason: Unable to update files in the library item. The source or destination may be slow or not responding.vCenter Server 8.x
この問題の根本原因は、VSM サービスのクラスパスに jar ファイルが不足していることです。
この問題は、VMware vCenter Server 8.0 Update 3b リリースで解決されています。ダウンロードするには、 Download Broadcom products and software にアクセスしてください。
回避策として、VSM サービスを再起動してサービス アカウントを再作成します。
service-control --restart vsm[サービス (Services)] に移動します。