NSX Manager is currently operating without a valid license is displayed in a banner in NSX Manager, but a valid license is assigned.
search cancel

NSX Manager is currently operating without a valid license is displayed in a banner in NSX Manager, but a valid license is assigned.

book

Article ID: 447048

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • The following banner is observed on the NSX Manager UI: "NSX Manager is currently operating without a valid license. To rectify this situation, please verify NSX Manager's license or entitlement from vCenter Server in the next ## days." 

  • A valid license is assigned on vCenter and on NSX which can be verified by:

    • For vCenter: Login to vSphere Client > Hamburger Menu > Administration > Licenses > Assets. Check if a valid license is assigned to the vCenter server and ESXi hosts alongside expiration.
    • For NSX Manager: Login to NSX Manager > Licenses. Check if valid license is assigned to NSX Manager and if they are valid.

  • As found in /var/log/proton/nsxapi.log suggests that the NSX Manager is currently in Grace Period with start time and duration along with logs indicating a connection issue between Compute Manager and NSX Manager
2026-05-22T14:34:37.594Z  INFO LicenseModeCheckTimer LicenseModeCheckTask 6039 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Check license group vc.vcf, mode GRACE_PERIOD, startTime <unix time>, duration <duration>
2026-06-13T06:56:48.628Z  WARN LogicalSwitchStateOperationScheduler2 VcConnectionImpl 5949 FABRIC [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Retry attempts 2 exhausted for loginByCertificateAsExtension
2026-06-13T06:56:48.628Z  WARN LogicalSwitchStateOperationScheduler2 CmObjectFinderImpl 5949 FABRIC [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Error occurred while getting dvpg info for cm ########-####-####-####-############, managed object ManagedObjectReference: type = VmwareDistributedVirtualSwitch, value = dvs-####, serverGuid = null,  Local ids null with query VDS
com.vmware.vim.vmomi.client.exception.ConnectionException: https://sdkTunnel:####/sdk/vimService invocation failed with "java.net.UnknownHostException: "<vCenter FQDN>"
  • NSX syslog found in /var/log/syslog indicates that the NSX Manager is unable to resolve the IP for vCenter FQDN (Note: Check on all 3 Manager nodes):
2026-06-14T05:00:57.460Z NSX 5949 SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Unable to find ip addresses for <vCenter FQDN>
  • Running API: POST https://<nsx-mgr>/api/v1/licenses/vcf/action/sync makes the banner disappear temporarily but does not fix the issue. 

Environment

VMware NSX

Cause

  • The issue is caused by a node-specific DNS resolution failure on one of the NSX Manager nodes for the vCenter Server FQDN.
  • The LicenseSynchronizeVCTask is a periodic timer that runs on a specific NSX Manager node to verify entitlements with vCenter.
  • When this task triggers on a node experiencing DNS issues, it fails to resolve the vCenter FQDN.
  • The failure triggers a disconnect event, causing the license group to transition to NON_ENTITLED.

Resolution

To permanently resolve the banner, identify and fix the DNS resolution failure on the specific NSX Manager node and ensure it is able to resolve vCenter FQDN.

  1. Login to the NSX manager as user admin
  2. Switch to the root user by running the command st en
  3. Run nslookup <vcenter-fqdn> and nslookup <vcenter-ip-address>. Ensure the vCenter's FQDN/IP is resolvable from all the NSX managers.
  4. If there is any issue with the DNS resolution, ensure the correct DNS server IPs are mentioned in the NSX manager /etc/resolv.conf file.

Note :- If the correct DNS server IPs are mentioned in /etc/resolv.conf, ensure that the NSX manager is able to reach the DNS server. Contact the DNS administrator team from the customer side to validate the DNS servers have proper forward and reverse lookup IPs for the vCenter server.

Additional Information

Banner stating NSX Manager is currently operating without a valid license

NSX Manager is currently operating without a valid license. To rectify this situation, please verify NSX Manager's license or entitlement from vCenter Server in the next <#> days