Upgrade to 7.9.2 or Higher Fails To Start Solr During cbupgrade Due to server.token MD5 Checksum
search cancel

Upgrade to 7.9.2 or Higher Fails To Start Solr During cbupgrade Due to server.token MD5 Checksum

book

Article ID: 446990

calendar_today

Updated On:

Products

Carbon Black EDR

Issue/Introduction

When upgrading to 7.9.2 or higher with a server.token with an MD5 checksum, Solr fails to startup during cbupgrade.

  • Checksum is MD5 (32 characters)
    grep 'checksum=' /etc/cb/server.token
  • cbupgrade fails with this error 
    Solr not running.
    Traceback (most recent call last):
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/utils/exceptions.py", line 164, in decorator
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/main.py", line 244, in main
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/main.py", line 71, in run
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/main.py", line 138, in __execute_actions
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/main.py", line 128, in run_actions
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/base_action.py", line 94, in do_execute
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/versions/v7_9_2.py", line 861, in execute
      File "/usr/share/cb/virtualenv/lib/python3.10/site-packages/cb/maintenance/cbupgrade/versions/v7_9_2.py", line 906, in _wait_for_solr
    Exception: Solr not running.

Environment

  • Carbon Black EDR Server: 7.9.2 and Higher

Cause

Servers installed prior to 6.5.0 will have a server.token with an MD5 checksum. 7.9.2 and higher no longer support MD5 checksums. 

Resolution

  1. Open a support case through your proper channel to get the server.token converted. 
  2. Provide the /etc/cb/server.token to the support case. For clustered environments, include the server.token for each primary and minion nodes. 
  3. Zip the server.token files up into a single zip, creating a folder for each node. For multiple servers, create a folder for each server with the minions in a subfolder.
    - server 1
    -- primary
    -- minion 1
    -- minion 2
    -server 2
    etc..
  4. Replace the server.token file(s) with the newly generated version(s). 
  5. Run cbupgrade to complete the upgrade. 

Additional Information

  • Clustered environments have the same token as the primary with node number added to the token, the checksum of each file will be different. 
  • The server.token is used in Alliance to differentiate servers under the customer token in the Alliance certificate. This allows Alliance to properly hand down binary reputation updates to the correct servers.