The NSX Manager UI displays an "Out of Sync" error for the affected ESXi host transport node.
Out Of Sync Error
Host configuration might be out of sync due to the following reasons:
The Transport Node is in a degraded or a partial success state. Try syncing the Transport Node configuration to resolve errors
Executing the nsxcli -c get managers command on the affected ESXi host shows one of the NSX Managers in a "Standby" state.
/var/log/syslog file on the NSX Manager contains the following error entries:2026-07-02T08:52:13.758Z Er(179) nsx-proxy[2100235]: NSX 2100235 - [nsx@6876 comp="nsx-esx" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2100265" level="ERROR" errorCode="RPC503"] RpcTransport[0]::RemoeService[XXXX-XXXX-XXXX-XXXX-XXXX] Failed to resolve service: 6-No such device or address026-07-02T08:52:13.892Z Er(179) nsx-proxy[2100235]: NSX 2100235 - [nsx@6876 comp="nsx-esx" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2100265" level="ERROR" errorCode="RPC503"] RpcTransport[0]::RemoeService[XXXX-XXXX-XXXX-XXXX-XXXX] Failed to resolve service: 6-No such device or address 2026-07-02T08:52:14.048Z Er(179) nsx-proxy[2100235]: NSX 2100235 - [nsx@6876 comp="nsx-esx" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2100265" level="ERROR" errorCode="RPC503"] RpcTransport[0]::Remo eService[XXXX-XXXX-XXXX-XXXX-XXXX] Failed to resolve service: 6-No such device or address 2026-07-02T08:52:14.050Z Er(179) nsx-proxy[2100235]: NSX 2100235 - [nsx@6876 comp="nsx-esx" subcomp="nsx-proxy" s2comp="nsx-rpc" tid="2100265" level="ERROR" errorCode="RPC503"] RpcTransport[0]::Remo eService[XXXX-XXXX-XXXX-XXXX-XXXX] Failed to resolve service: 6-No such device or address
VMware NSX
The Appliance Proxy Hub (APH) and LocalManager certificates on the NSX-T Manager have expired. This expiration breaks the Remote Procedure Call (RPC) trust and communication framework between the NSX Manager and the ESXi host transport node.
Replace the expired certificates based on the deployed type:
For Self-Signed Certificates: Run the Certificate Analyzer Resolver (CARR) script to renew the expired certificates. For instructions, refer to Using Certificate Analyzer Resolver (CARR) script to resolve NSX certificate issues.
For CA-Signed Certificates: Replace the expired certificates using the NSX API. For detailed instructions, refer to the Replace Certificates Through API documentation.
Once the certificates are successfully replaced and trust is restored, proceed to re-install the NSX-T VIBs on the problematic ESXi host to complete the transport node preparation.