ESXi hosts might fail with a purple diagnostic screen when on a Dell server.
* Upgrade to certain TPM firmware version 7.2.4.1 or later
* Then re-install ESXi
VMware ESXi 8.0
This issue is resolved in the VMware ESXi 8.0 Update 3j (Build 25429389)
VMware ESXi 8.0 Update 3j Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3j-release-notes.html
The workaround could be found at:
VMware vSphere ESXi 8.x on Dell PowerEdge Systems Release Notes
https://www.dell.com/support/manuals/en-sr/vmware-esxi-8.x/vmware_8.x_pub_rn/known-issues?guid=guid-ea80ce97-07db-402f-a99c-36109663f276&lang=en-us
The Issue ID 360248