Error: No logs found during log collection due to 30 second timeout in vCloud Director
search cancel

Error: No logs found during log collection due to 30 second timeout in vCloud Director

book

Article ID: 446819

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VMware Cloud Director

Issue/Introduction

  • In the Cloud Director UI, the log tab of the 'Edge' > 'Services' > 'Firewall' menu displays the following error when querying edge firewall logs; 'No logs found'
  • When making a firewall log query in Cloud Director, In the linked Operations for Logs instance, in the 'Active Query' tab of the 'System Monitor' section of the 'Management' menu , an active query appears and disappears after exactly 30 seconds.

Environment

  • Cloud Director 10.6.x
  • Aria Operations for Logs 8.18.x

Cause

The 30-second timeout is expected behaviour for this integration. API queries originating from VMware Cloud Director are unoptimized. Large or complex queries exceed the 30-second execution threshold

Resolution

This is a known issue and there is currently work being carried out to optimize the API call being made by Cloud Director to Aria Operations for Logs.

This was resolved in VMware Cloud Director 10.6.2. Please refer to the Release Notes' Known Issues. This specific issue is found under Distributed Firewall (DFW) logs are not visible in the VMware Cloud Director UI.