Lifecycle Manager Sync Updates Fail with "Two baseimages share the same releaseID" when created from PowerCli
search cancel

Lifecycle Manager Sync Updates Fail with "Two baseimages share the same releaseID" when created from PowerCli

book

Article ID: 446795

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Images created using older version of Powercli
  • When synchronizing updates in VMware vCenter Server 9.1 Lifecycle Manager (vLCM), the task fails with error A general system error occurred: "A depot is inaccessible or has invalid contents. Make sure an official depot source is used and verify connection
  • /var/log/vmware/vmware-updatemgr/vum-server/imageservice.log reports below errors.

YYYY-MM-DD 11:20:54,245 ERROR imageService[139722843671424] [imageService 457] Unable to connect to depot(s) https://sddc_fqdn/vmware/vcf/umds/patch-store/hostupdate/__hostupdate20-consolidated-index__.xml: ('ESXi:9.1.0-0.25370933', 'baseimage', "Two baseimages share the same releaseID: ESXi:9.1.
0-0.25370933, but have different attributes: versionSpec ('<VersionSpec version: 9.1.0-0.25370933; uiString: 9.1.0.0.25370933>' != '<VersionSpec version: 9.1.
0-0.25370933; uiString: 9.1.0.0.25370933; vcfVersion: 9.1.0.0.25370933>'), swPlatforms ('[]' != '[{'version': '9.1', 'locale': '', 'productLineID': 'esxio'},
{'version': '9.1', 'locale': '', 'productLineID': 'embeddedEsx'}]')")
YYYY-MM-DD 11:20:54,246 ERROR imageService[139722843671424] [imageService 457] Failed to validate depot: ('ESXi:9.1.0-0.25370933', 'baseimage', "Two baseimage
s share the same releaseID: ESXi:9.1.0-0.25370933, but have different attributes: versionSpec ('<VersionSpec version: 9.1.0-0.25370933; uiString: 9.1.0.0.2537
0933>' != '<VersionSpec version: 9.1.0-0.25370933; uiString: 9.1.0.0.25370933; vcfVersion: 9.1.0.0.25370933>'), swPlatforms ('[]' != '[{'version': '9.1', 'loc
ale': '', 'productLineID': 'esxio'}, {'version': '9.1', 'locale': '', 'productLineID': 'embeddedEsx'}]')")
YYYY-MM-DD 11:20:54,246 INFO imageService[139722843671424] [imageService 457] Updated hearbeat time YYYY-MM-DDT11:20:54.246Z for task 5281dd26-9b5e-ab5f-00f0-
cc4d28c22f7c

 

Environment

VCF 9.1

 

Cause

This can happen when a depot was generated with a mix of older and newer PowerCLI versions. The 1st depot imported to the VC will go through. But the 2nd one will fail due to conflict with the previous one

Resolution

  • This issue is addressed for Windows in newer PowerCLI  9.1 release
  • Use a latest VCF powerCLI versions to build the esxi image