Connector communication failed because of invalid data: Problem connecting to directory: Host {0}, Reason - {1}connector.log' and 'connector-dir-sync.log' found in '/opt/vmware/horizon/workspace/logs' the following types of errors can be observed;simple bind failed: <AD_FQDN>:636Caused by: java.security.cert.CertificateExceptioncom.vmware.horizon.directory.ldap.exceptions.DirectoryConnectionException: Could not connect to the Domain Controller.
The full certificate chain need to be in the SSL field of the directory confguration.
Pull the full Domain certificate from the AD server and add it to the SSL configuration.
Retrieve the full AD certificate chain from the AD server by executing the following command from the vIDM appliance CLI:
openssl s_client -showcerts -connect <Your_AD_FQDN>:<port> </dev/null
Copy the certificate output to a text editor.
Clean up the certificate formatting by removing any trailing blank spaces and ensuring each certificate in the chain has a distinct '-----BEGIN CERTIFICATE-----'and '-----END CERTIFICATE-----' marker.
Paste the cleaned certificate chain into the SSL Certificate field of the directory configuration in the vIDM UI.
Save and trigger a directory sync.