Unable to configure and sync a directory in VMware Identity Manager
search cancel

Unable to configure and sync a directory in VMware Identity Manager

book

Article ID: 446793

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When attempting to validate using the bind password, the following error is received;
Connector communication failed because of invalid data: Problem connecting to directory: Host {0}, Reason - {1}
  • In 'connector.log' and 'connector-dir-sync.log' found in '/opt/vmware/horizon/workspace/logs' the following types of errors can be observed;
simple bind failed: <AD_FQDN>:636
Caused by: java.security.cert.CertificateException
com.vmware.horizon.directory.ldap.exceptions.DirectoryConnectionException: Could not connect to the Domain Controller.

Environment

  • VMware Identity Manager 3.3.7

Cause

The full certificate chain need to be in the SSL field of the directory confguration.

Resolution

Pull the full Domain certificate from the AD server and add it to the SSL configuration.

  1. Retrieve the full AD certificate chain from the AD server by executing the following command from the vIDM appliance CLI:

    • openssl s_client -showcerts -connect <Your_AD_FQDN>:<port> </dev/null

  2. Copy the certificate output to a text editor.

  3. Clean up the certificate formatting by removing any trailing blank spaces and ensuring each certificate in the chain has a distinct '-----BEGIN CERTIFICATE-----'and '-----END CERTIFICATE-----' marker.

  4. Paste the cleaned certificate chain into the SSL Certificate field of the directory configuration in the vIDM UI.

  5. Save and trigger a directory sync.