VMware vSphere Replication において、複数世代(Points In Time)保持ポリシーが設定された仮想マシンのレプリケーションステータスが「エラー」になります。
Site Recovery GUI での vSphere Replication の仮想マシンのレプリケーション表示にて以下のようなエラーメッセージが記録されます。
"レプリケーション「<仮想マシン名>」の vSphere Replication サーバでレプリケーション エラーが発生しました。詳細: 「Error for (datastoreUUID: "データストアのUUID>"), (diskId: "RDID-####"), (pathname: "該当データストアのパス"), (flags: retriable, objlib-error): Set error flag: objlib-error; Class: ObjLib Code: 1441796; ObjLib error: Invalid argument; Set error flag: retriable; On sending bitmap for region starting at 1874853888; Invalid argument; Failed to combine files ... Prune disks could not remove disk instance ... While completing partial prune」"
DR(ターゲット)サイト側で保持ポリシーから外れた最も古いスナップショット(差分ディスク)のベースディスクへの自動統合(Prune/Consolidate)処理が失敗し、レプリケーションの同期が停止したためのエラーとなります。
vSphere Replication 9.x
このエラーは、ターゲットサイト側のストレージ容量不足や制限により、古いスナップショットの統合(Prune/Consolidate)処理において物理的な書き込み I/O が失敗することで発生します。
主な要因は以下の通りです:
書き込み I/O が失敗すると統合処理が完了せず、古い差分ファイルがクリーンアップされないままロックが保持され、ディスクチェーンの累積や同期の停止を招きます。
以下の対処にて該当仮想マシンのレプリケーションエラーの解消してください。
ストレージ側の物理的な書き込み制限が解除された後、ターゲットホストのvSphere Replication サーバー(hbrsrv)のリトライ機能によって、バックグラウンドでのディスク統合処理(consolidateProgress)が 実施されます。vSphere Replication の仮想マシンのレプリケーション表示にて”ディスク統合が進行中”にて進捗を確認し、正常に完了した後、ステータスが「正常」に復旧することを確認します。
ストレージでの対処後にてもディスク統合処理が完了しない場合や、差分ディスクチェーンの不整合が解消されない場合は、該当仮想マシンのレプリケーションを一度停止(Stop)し、既存のターゲットディスクをレプリケーションシード(Seed)として指定してレプリケーションの再構成を実施します。
ストレージにて物理の空き容量が減って閾値を下回ると上記の KB の様なイベントが確認できます。