Browser Agent response cookie insertion impacting application.
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Browser Agent response cookie insertion impacting application.

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Article ID: 4467

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

  There are various symptoms: the most common one is Customer Application Session authorization data lost when Browser Agent is enabled.

Environment

APM 10.1-10.3

Cause

  Size of response cookies. See http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1281806.html

Resolution

  1.Disable Browser Agent.
  2.Or disable Browser Agent response cookie insertion. To do this, you need to apply HF and set appropriate property:
    (Note: the property name is not same for each versions):

    a.10.1 HF#13 (DE130151): introscope.agent.brtm.cookieInsertionEnabled=false
    b.10.2 HF#22 (DE237930): introscope.agent.browseragent.cookieInsertionEnabled=false
    c.10.3 HF#11 (DE224580): introscope.agent.brtm.cookieInsertionEnabled=false

 Note: Impact of disabling BRTM response cookies:

 1) BRTM metrics will be showing up in different path and without browser info (like BT unmatched  BRTM metrics):So instead of:

   Business Segment | <Business_Service>| <Business_Transaction> via Chrome | <Business_Transaction_Component> | Browser | <Browser_Metrics>
 

   It will be:
   

   Business Segment | <Host>/<Port> | <URL> | <Browser_Metrics>

 2) BRTM will not be involved in Transaction Tracing and send traces.

 

 

Additional Information

A future release may add additional properties/clamps to control the cookies size/number.