Cloned VM fails to power on in vSAN Data Protection when name contains special characters
search cancel

Cloned VM fails to power on in vSAN Data Protection when name contains special characters

book

Article ID: 446575

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Virtual Machine fails to power on immediately after cloning a snapshot from vSAN Data Protection.

In vCenter, when trying to power on the VM, you may receive an error message similar to the following:

File <VM_Name (ID)>.vmdk was not found Failed to start the virtual machine. Module Disk power on failed. Cannot open the disk '<VM_Name (ID)>.vmdk' or one of the snapshot disks it depends on. The system cannot find the file specified VMware ESXi cannot find the virtual disk "<VM_Name (ID)>.vmdk". Verify the path is valid and try again.

Environment

  • VMware vSphere ESXi 8.0.x

  • VMware Cloud Director (VCD)

  • vSAN Data Protection

 

Cause

Issue is caused by special characters (specifically parentheses ( )) in the VM name.

Resolution

Broadcom is aware of this issue and is working on a resolution.

As a workaround, perform the following steps to manually remove the special characters:

  1. Rename the VM in the inventory to exclude special characters before attempting the clone or power-on.

  2. Remove the special characters from the VM snapshot file names.

  3. Remove the special characters from within the VM's .vmx configuration file.

  4. Unregister and re-register the VM in the inventory after performing the changes to the file names and the .vmx configuration file.

Additional Information

CBT (Changed Block Tracking) status does not impact this specific failure.