Attempts to re-register or re-connect an existing Cloud Proxy appliance to a VCF Operations cluster fail after the proxy has been removed. This typically occurs when a Cloud Proxy is removed for troubleshooting or during upgrades (such as VCFA upgrade to 9.1) and needs to be restored.
This is expected behavior. A Cloud Proxy appliance cannot be reconnected to the VCF Operations cluster once it has been removed from the inventory within the VCF Operations UI.
To reuse the same hostname and IP address for a Cloud Proxy, deploy a new appliance using these steps: