Workload Appliance Fails to Register - No vCenter Servers Associated with SSO Found
search cancel

Workload Appliance Fails to Register - No vCenter Servers Associated with SSO Found

book

Article ID: 446533

calendar_today

Updated On:

Products

Carbon Black Cloud Workload

Issue/Introduction

Carbon Black Workload Appliance is failing to register and the Registration page UI displays:

vCenter Server hostname: Not Set. No vCenter Servers associated with SSO found

Environment

  • Carbon Black Cloud Workload: All Supported Versions

Cause

  • DNS/Network
    • The appliance needs to be able to resolve the Fully Qualified Domain Name (FQDN) of the vCenter server. If the vCenter server is operating in Enhanced Linked Mode (ELM), the appliance must also have network access to every vCenter node within the ELM environment.
  • NTP
    • If the clocks are out of sync, the SSO token exchange will fail.
  • Expired/ Invalid vCenter certificates
    • If the vCenter certificates are expired or invalid, the SSO token exchange will fail.

Resolution

  1. Confirm connectivity between the Workload Appliance and the vCenter(s). To change network settings of the appliance see How To View And Update Network Settings For The Appliance
    Test FQDN Connectivity:
    curl -v <vCenterFQDN>
    
    Check DNS Resolution:
    nslookup <vCenterFQDN>
  2. Confirm the NTP Server Settings
  3. Confirm that none of the certificates being used vCenter SSO are expired:
    openssl s_client -connect <vCenterFQDN>:443 -showcerts