Sender Policy Framework (SPF) validation fails for specific domains, resulting in emails being quarantined or rejected. This occurs when the number of DNS TXT records for the domain is too large for standard UDP resolution.
Version: 10.9.0 - 10.9.2
The SERVFAIL return is caused by a built-in security safeguard. The DNS name resolution service enforces a default limit of 100 records per type per domain name (RRset limit).
The issue will be addressed in Messaging Gateway version 10.9.3