When attempting to import a vCenter Add "Validation Failed", "VCF 9.x Brownfield via the user interface path VCF Operations > Operate > Inventory > VCF Instances > ADD WORKLOAD DOMAIN, the execution fails during the precheck validation phase.
YYYY-MM-DDThh:mm:ss.643+0000 ERROR [vcf_om,6a3cf3f62d246ea95c8c683ea1a21f52,8a42] [c.v.e.s.c.c.CertificateRetrustService,pool-2-thread-20] Failed to retrust with the server https://<REDACTED_HOSTNAME>/certificate-management/certificate-bundle, error Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false')
YYYY-MM-DDThh:mm:ss.643+0000 ERROR [vcf_om,6a3cf3f62d246ea95c8c683ea1a21f52,8a42] [c.v.v.c.n.s.c.c.NsxtConnectionFactory,pool-2-thread-20] Failed to perform the retrust operation with the server: <REDACTED_HOSTNAME>
YYYY-MM-DDThh:mm:ss.643+0000 ERROR [vcf_om,6a3cf3f62d246ea95c8c683ea1a21f52,8a42] [c.v.e.s.c.v.primitive.NsxtValidator,pool-2-thread-20] Failed to validate NSX <REDACTED_HOSTNAME> connectivity
com.vmware.vapi.client.exception.SslException: Certificate for <REDACTED_HOSTNAME> doesn't match any of the subject alternative names: [<REDACTED_HOSTNAME_SHORT>]Caused by: javax.net.ssl.SSLPeerUnverifiedException: Certificate for <REDACTED_HOSTNAME> doesn't match any of the subject alternative names: [<REDACTED_HOSTNAME_SHORT>]
VMware Cloud Foundation 9.x
To resolve this issue, all node FQDNs plus the VIP FQDN must be in the SAN.
For comprehensive guidance regarding alternative certificate replacement techniques, see Replace Certificates Through NSX Manager.