Internal Server Error./opt/vmware/vcloud-director/logs/vcloud-container-debug.log on the Cloud Director cell displays logs such as:java.lang.NullPointerException at com.vmware.ssdc.backend.services.impl.ProviderVdcManagerImpl.isRootResourcePoolInYellowState(ProviderVdcManagerImpl.java:1617) at com.vmware.ssdc.backend.services.impl.ProviderVdcManagerImpl.isPrimaryRootResourcePoolInYellowState(ProviderVdcManagerImpl.java:1601) at com.vmware.vcloud.valc.util.ConfigUtil.validateProviderVdcState(ConfigUtil.java:377)WARN | ComputeHubSetImpl | Failed to locate the backing resource [vcId=..., moref=resgroup-####]DEBUG | AbstractEventBuilder | Could not find property 'resourcePool.moref' in source object.VMware Cloud Director 10.6.x
This issue occurs if the underlying vCenter Resource Pool (referenced by a specific Managed Object Reference ID or "MoRef") has been deleted, recreated with a different ID, or moved. Cloud Director’s database continues to reference the stale MoRef. When the isRootResourcePoolInYellowState method is called, it fails to resolve the object, resulting in a NullPointerException
To resolved the issue, confirm that the resource pool exists in the vCenter Server. Once confirmed that it does exist, perform a reconnect of vCenter Server from Cloud Director in order to synchronize the managed object reference state.
https://vcenter.example.com/mob/moid=resgroup-####
If the resource pool does not exist, perform the following remediation steps: