ESX Image missing in VCF Operations Image Management
search cancel

ESX Image missing in VCF Operations Image Management

book

Article ID: 446269

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VMware Cloud Foundation

Issue/Introduction

  • ESX 9.1 Image not listed while configuring Upgrade plan on VCF Operations

Build -> Lifecycle -> VCF Instances -> Domain -> Upgrades -> Edit Plan

  • Sync Update on vCenter Server using vSphere Client fails with "HTTP Error 404"
  • /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log: (on VC)

YYYY-MM-DDTHH:MM:SS INFO vmware-vum-server 657152 [vc@4413 sub="httpDownload"] [httpDownloadPosix 772] curl_easy_perform() succeeded - url: https://<SDDC Manager>/vmware/vcf/umds/patch-store/hostupdate/__hostupdate20-consolidated-index__.xml
YYYY-MM-DDTHH:MM:SS DEBUG vmware-vum-server 657152 [vc@4413 sub="httpDownload"] [httpDownloadPosix 740] Cleanup SSL context
YYYY-MM-DDTHH:MM:SS INFO vmware-vum-server 657152 [vc@4413 sub="ServiceProviderCommonLogger"] [Common 341] Output Json : {"info": [], "warnings": [], "errors": [{"id": "com.vmware.vcIntegrity.lifecycle.EsxImage.MetadataDownloadErrorV2", "message": {"id": "com.vmware.vcIntegrity.lifecycle.EsxImage.MetadataDownloadErrorV2", "default_message": "An error occurred while downloading depot metadata from 'https://<SDDC Manager>/vmware/vcf/umds/patch-store/hostupdate/vmw/metadata-14945461.zip': '('https://<SDDC Manager>/vmware/vcf/umds/patch-store/hostupdate/vmw/metadata-14945461.zip', '/tmp/tmp1yo5zfxg', 'HTTP Error 404: Not Found')'. Please refer to KB 313508 for more details.", "args": ["https://<SDDC Manager>/vmware/vcf/umds/patch-store/hostupdate/vmw/metadata-14945461.zip", "('https://<SDDC Manager>/vmware/vcf/umds/patch-store/hostupdate/vmw/metadata-14945461.zip', '/tmp/tmp1yo5zfxg', 'HTTP Error 404: Not Found')"]},

Environment

VCF 9.1

Cause

The issue is caused by missing or corrupted metadata files (e.g., `metadata-XXXXXX.zip`) within the SDDC Manager patch-store repository. This typically occurs due to partial downloads, temporary disk space exhaustion on the SDDC Manager, or accidental manual deletion of repository files.

Resolution

Proceed with the repository cleanup of the SDDC Manager Patch Store and re-download the patch binaries.

Cleanup Patch store on SDDC Manager

  1. Log in to the SDDC Manager via SSH as the `vcf` user and switch to `root`
  2. Navigate to the patch-store directory and remove its contents

    rm -rf /nfs/vmware/vcf/nfs-mount/umds/patch-store/*

  3. Restart the Lifecycle Management (LCM) service

    systemctl restart lcm

Repository Synchronization

  1. Log in to the VCF Operations UI.
  2. Navigate to Build > Lifecycle > VCF Management and select Sync
  3. Log in to the vCenter using vSphere Client.
  4. Navigate to Lifecycle Manager > Actions and select Sync Updates to ensure the vCenter retrieves the new metadata from SDDC Manager.

Re-create and Import the Image

  1. In the vSphere Client, go to Lifecycle Manager > Image Library and select Create Image to define the desired ESXi configuration
  2. Return to the SDDC Manager UI
  3. Navigate to Lifecycle Management > Image Management > Import Image
  4. Select the target vCenter and the newly created image name, then click Import.

Update the Upgrade Plan

  1. In the VCF Operations UI, navigate to Build > Lifecycle > VCF Instance
  2. Select the instance and update the ESX upgrade plan with the newly imported image