In some environments, part of the vSAN header traffic might get corrupted and cause vSAN hosts to fail with a purple diagnostic screen.
Follow log could be found in the ESXi logs.
--vmkernel.log--YYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu26:2098462)RDT: RDTRDMAConnectionSendMbufTo:5391: connection in errorYYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu26:2098462)RDT: RDTRDMAConnectionSendMbufTo:5391: connection in error...YYYY-MM-DDTHH:MM:SSZ Wa(180) vmkwarning: cpu2:2121740)WARNING: ZDOMBLKCACHE: CACHE_SLOW: X Block {########-####-####-####-############, 82, 23468760}, type: SegUsageBlk blocked 6.7 sec.YYYY-MM-DDTHH:MM:SSZ Wa(180) vmkwarning: cpu2:2121740)WARNING: ZDOMBLKCACHE: CACHE_SLOW: X Block {########-####-####-####-############, 82, 23468760}, type: SegUsageBlk blocked 7.4 sec.
VMware ESXi 8.0
This issue is resolved in the VMware ESXi 8.0 Update 3j (Build 25429389).
The fix adds full header checksum verification of the vSAN header traffic.
This verification ensures the integrity of vSAN header traffic by detecting data corruption or tampering during transmission, which improves resiliency and avoids potential failure.
VMware ESXi 8.0 Update 3j Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3j-release-notes.html