Cannot insert the value NULL into column 'RPT_INSTANCE_ID'
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Cannot insert the value NULL into column 'RPT_INSTANCE_ID'

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Article ID: 44621

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Updated On:

Products

CA Virtual Privilege Manager CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Reports cannot get generated. When trying to schedule a report in Enterprise Management, there is an error about inserting a null value into a table. The full error is below.

SmApiWrappedException:Cannot insert the value NULL into column 'RPT_INSTANCE_ID', table 'database.dbo.RPTINSTANCE'; column does not allow nulls. INSERT fails.

 

Environment

Privileged Identity Manager 12.9 SP1 integrated with CABI

Cause

The reason the error occurs is because the RPT_INSTANCE_ID table does not accept null values. The value being inserted should not be null, but is null because the biar file did not get imported properly. If you log into Java Infoview and go to the Privileged Identity Management reports, you will notice that the crystal reports are missing.

Resolution

To resolve the issue, use the biconfig utility to import the biar file again.

Example:

biconfig.bat -h reportportal.comp.com -u Administrator -p P@ssw0rd -f C:\BO\import_biar_config_oracle11g.xml

 

After importing the biar file again, log back into Java Infoview to verify that the import was successful. If all the report types are listed and the issue still occurs, please open a case with support.

Additional Information

For more information on the biconfig utility, please refer to our Implementation Guide.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-identity-manager/12-9-01/implementing/enterprise-reporting/set-up-the-environment-for-enterprise-reporting/deploy-a-report-package-on-the-report-portal.html