Scheduled file-based backups for the vCenter Server Appliance (vCSA) fail intermittently. Observed symptoms include:
var/log/vmware/applmgmt/backup.log on the vCenter Server:<date><time> [MainProcess:PID-260325] [BackupManager::main:BackupManager.py:618] INFO: Starting backup job...<date><time> [MainProcess:PID-260325] [BackupManager::main:BackupManager.py:625] INFO: Scheduled Backup triggerd<date><time> [LotusBackup:PID-263682] [Proc::GetProcsStatus:Proc.py:383] ERROR: rc: 28, stderr: b'curl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\ncurl: (28) Timeout was reached\n'
C:\ProgramData\SSH\logs\sshd.log on the Windows SFTP server:<date><time> error: lookup_principal_name: User principal name lookup failed for user '<backup_username>' (explicit: 1722, implicit: 1722)<date><time> fatal: ga_init, unable to resolve user <backup_username>
vCenter Server 8.x
This issue occurs when a Windows-based SFTP server (such as Win32-OpenSSH) uses a domain account for authentication.
Intermittently, the Windows SFTP server loses connectivity to the Domain Controller (DC) while trying to resolve the user principal. This triggers a Windows RPC error 1722 (RPC_S_SERVER_UNAVAILABLE). Because the server hangs while waiting for the DC response, the vCenter curl session receives no data and eventually times out.
To resolve this issue, follow either of the below options: