Remote Viewer slow login connection performance
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Remote Viewer slow login connection performance

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Article ID: 44601

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Updated On:

Products

Automation Point

Issue/Introduction

When there is setup of a very secure network for connections to outside networks, and another more open network for our user base, the Automation Point servers are on the more secure network. Firewall rules are in place to allow communication on Port 5500 from the user network to the secure network. When a Remote Viewer connection is initiated it can take any where from 1 - 5 minutes for the connection to be established. Wireshark sniffers show the initial communication on Port 5500 happens quickly and successfully but then the server/application appears to be requesting NetBIOS info and does this over and over. At some point it gives up on this and establishes communication on Port 5500 and the Remote Viewer connection is completed. 

Environment

All Supported Windows Server environments 
All supported Automation Point releases

Cause

The issue is caused by the behavior of Windows Servers using NetBIOS, as well as DNS to resolve IP addresses using gethostbyaddr() Windows API in the Automation Point source (the Remote Manager component, specifically). The NetBIOS communication is causing the delay in the connection, so turn off NetBIOS to resolve the problem.

Resolution

  1. From the Control Panel select View network status and tasks , select the Network connection displayed and then Properties at the General tab.

  2. On the Networking tab, click Internet Protocol Version 4 (TCP/IPv4) in the list of components, and click the Properties button.

  3. Click the Advanced button at this General tab.

  4. At the Advanced TCP/IP Settings window, select the WINS tab. Select Disable NetBIOS over TCP/IP at the NetBIOS setting (at the bottom) .

Additional Information

See this Microsoft TechNet article for more information about disabling NetBIOS over TCP/IP