ESXi might fail with a purple diagnostic screen when use a Paravirtual Remote Direct Memory Access (PVRDMA) device
search cancel

ESXi might fail with a purple diagnostic screen when use a Paravirtual Remote Direct Memory Access (PVRDMA) device

book

Article ID: 445970

calendar_today

Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

An ESXi might fail with a purple diagnostic screen at follow situation.

  • ESXi is under memory pressure
  • The Paravirtual Remote Direct Memory Access (PVRDMA) device was in used
  • A RDMA-capable physical NIC is from down to up

Before ESXi panic, it's observed that the PVRDMA was failed to acquire resources when the RDMA-capable NIC was linked up.
--vmkernel.log
YYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu34:#######)VRDMA: 2406: RDMA Device vmrdma0 with uplink vmnic4 attached to adapter 0
YYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu34:#######)VRDMA: 2448: PVRDMA Batch mode for DMR MR WRs to HCA is allowed
YYYY-MM-DDTHH:MM:SSZ Wa(180) vmkwarning: cpu34:#######)WARNING: VRDMA: vm #######: 67: Failed to create physical completion queue: Failure

Environment

VMware ESXi 8.0

Cause

If an ESXi host does not have enough memory available, RDMA-capable NICs might fail to create RDMA resources. 
If such a condition occurs while a PVRDMA virtual device backed by the RDMA-capable NIC is restored from down to up state, 
the ESXi host might fail with a purple diagnostic screen.

Resolution

This issue is resolved in the VMware ESXi 8.0 Update 3i (Build 25205845)

Additional Information

VMware ESXi 8.0 Update 3i Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3i-release-notes.html