An ESXi might fail with a purple diagnostic screen at follow situation.
Before ESXi panic, it's observed that the PVRDMA was failed to acquire resources when the RDMA-capable NIC was linked up.--vmkernel.logYYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu34:#######)VRDMA: 2406: RDMA Device vmrdma0 with uplink vmnic4 attached to adapter 0YYYY-MM-DDTHH:MM:SSZ In(182) vmkernel: cpu34:#######)VRDMA: 2448: PVRDMA Batch mode for DMR MR WRs to HCA is allowedYYYY-MM-DDTHH:MM:SSZ Wa(180) vmkwarning: cpu34:#######)WARNING: VRDMA: vm #######: 67: Failed to create physical completion queue: Failure
VMware ESXi 8.0
If an ESXi host does not have enough memory available, RDMA-capable NICs might fail to create RDMA resources.
If such a condition occurs while a PVRDMA virtual device backed by the RDMA-capable NIC is restored from down to up state,
the ESXi host might fail with a purple diagnostic screen.
This issue is resolved in the VMware ESXi 8.0 Update 3i (Build 25205845)
VMware ESXi 8.0 Update 3i Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3i-release-notes.html