「ホスト再構築の予約」または「操作の予約」が設定されていたクラスタにおいて vSAN を無効にした場合、そのクラスタでvSANを再度有効化しようとすると、次の警告が表示されて失敗します。
"キャパシティ予約が有効になっている vSAN クラスタで、フォルト ドメインの構成はサポートされません。" ("Configuring fault domains on a vSAN cluster with capacity reservation enabled is not supported.")
この記事の目的は、この問題について説明し、実行可能な回避策を提供することです。
VMware vSAN 8.0.x
この問題は、vCenterがvSAN有効化ワークフローを再度実施しようとした際に、クラスタ構成を正しく解析できなかったことで発生します。
本事象は vCenter Server 8.0 Update 3 にて修正されています。
回避策:
vSAN構成ワークフローの「フォルト ドメイン」セクションで、クラスタ内の各ノードに対してフォルトドメインを作成します。各フォルトドメインには、1つのノードのみを含める必要があります。
これにより、ワークフロー エラーを回避し、vSANが再び有効になります。
完了後、フォルトドメインの設定セクションに移動し、各ホストをそれぞれのフォルトドメインから「スタンドアローン ホスト」セクションにドラッグすることでフォルトドメインを削除できます。
クラスタ上で「ホスト再構築の予約」または「操作の予約」が構成されている状態でvSANが無効化された場合、再度有効化しようとするとエラーメッセージが表示されて失敗します。
Cannot configure vSAN on a cluster with previously enabled vSAN capacity reservation.