Jobs stuck in READY state after reinstalling an agent
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Jobs stuck in READY state after reinstalling an agent

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Article ID: 44581

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Updated On:

Products

Workload Automation Agent CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

After successfully re-installing the agent, scheduled jobs as well as jobs that are manually triggered are getting stuck in READY state.

Environment

Workload Automation DE (dSeries): All versions

Cause

Job in Ready state indicates Agent and Manager communication issue. The Agent's receiver and transmitter logs should be reviewed to determine the root cause.

For example, the following error can is noted in the agent's receiver log.

07/04/2016 05:46:37.550 EDT-0400 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:2>.CybReceiverChannel.receive[:213] - Can't parse the message: cybermation.library.communications.CybConversationWrongMessageException: Unknown manager .NAK sent 

The 'Unknown manager' message exception implies that the manager ID is unknown to the Agent.

Resolution

The following setting in the agentparm.txt defines the schedling manager

communication.managerid_1=<manager ID> 


Steps:

  1. On the Desktop Client CLI perspective, issue the about command to verify the DE manager ID
    CA Workload Automation Server Id: <manager ID>

  2. Copy the manager ID to replace the wrong manager ID in agentparm.txt file;
    communication.managerid_1=<manager ID>

  3. Restart the agent